Configuration Level Command ListΒΆ

comment <config node> "comment text"

commit

commit-confirm <minutes>

compare <saved | N> <M>

copy

delete

delete protocols static route 0.0.0.0/0

exit [discard]

load <URI>

loadkey <username> <location>

rename

rollback <N>

run

save

set

set firewall all-ping [enable | disable]

set firewall broadcast-ping [enable | disable]

set firewall group address-group <name> address [address | address range]

set firewall group address-group <name> description <text>

set firewall group ipv6-address-group <name> address <address>

set firewall group ipv6-address-group <name> description <text>

set firewall group ipv6-network-group <name> description <text>

set firewall group ipv6-network-group <name> network <CIDR>

set firewall group network-group <name> description <text>

set firewall group network-group <name> network <CIDR>

set firewall group port-group <name> description <text>

set firewall group port-group <name> port [portname | portnumber | startport-endport]

set firewall ip-src-route [enable | disable]

set firewall ipv6-name <name> default-action [drop | reject | accept]

set firewall ipv6-name <name> description <text>

set firewall ipv6-name <name> enable-default-log

set firewall ipv6-name <name> rule <1-9999> action [drop | reject | accept]

set firewall ipv6-name <name> rule <1-9999> description <text>

set firewall ipv6-name <name> rule <1-9999> destination address [address | addressrange | CIDR]

set firewall ipv6-name <name> rule <1-9999> destination group address-group <name>

set firewall ipv6-name <name> rule <1-9999> destination group network-group <name>

set firewall ipv6-name <name> rule <1-9999> destination group port-group <name>

set firewall ipv6-name <name> rule <1-9999> destination port [1-65535 | portname | start-end]

set firewall ipv6-name <name> rule <1-9999> disable

set firewall ipv6-name <name> rule <1-9999> log [disable | enable]

set firewall ipv6-name <name> rule <1-9999> protocol [<text> | <0-255> | all | tcp_udp]

set firewall ipv6-name <name> rule <1-9999> source address [address | addressrange | CIDR]

set firewall ipv6-name <name> rule <1-9999> source group address-group <name>

set firewall ipv6-name <name> rule <1-9999> source group network-group <name>

set firewall ipv6-name <name> rule <1-9999> source group port-group <name>

set firewall ipv6-name <name> rule <1-9999> source mac-address <mac-address>

set firewall ipv6-name <name> rule <1-9999> source port [1-65535 | portname | start-end]

set firewall ipv6-name <name> rule <1-9999> state [established | invalid | new | related] [enable | disable ]

set firewall ipv6-name <name> rule <1-9999> tcp flags <text>

set firewall ipv6-receive-redirects [enable | disable]

set firewall ipv6-src-route [enable | disable]

set firewall log-martians [enable | disable]

set firewall name <name> default-action [drop | reject | accept]

set firewall name <name> description <text>

set firewall name <name> enable-default-log

set firewall name <name> rule <1-9999> action [drop | reject | accept]

set firewall name <name> rule <1-9999> description <text>

set firewall name <name> rule <1-9999> destination address [address | addressrange | CIDR]

set firewall name <name> rule <1-9999> destination group address-group <name>

set firewall name <name> rule <1-9999> destination group network-group <name>

set firewall name <name> rule <1-9999> destination group port-group <name>

set firewall name <name> rule <1-9999> destination port [1-65535 | portname | start-end]

set firewall name <name> rule <1-9999> disable

set firewall name <name> rule <1-9999> log [disable | enable]

set firewall name <name> rule <1-9999> protocol [<text> | <0-255> | all | tcp_udp]

set firewall name <name> rule <1-9999> source address [address | addressrange | CIDR]

set firewall name <name> rule <1-9999> source group address-group <name>

set firewall name <name> rule <1-9999> source group network-group <name>

set firewall name <name> rule <1-9999> source group port-group <name>

set firewall name <name> rule <1-9999> source mac-address <mac-address>

set firewall name <name> rule <1-9999> source port [1-65535 | portname | start-end]

set firewall name <name> rule <1-9999> state [established | invalid | new | related] [enable | disable ]

set firewall name <name> rule <1-9999> tcp flags <text>

set firewall options interface <interface> adjust-mss <number-of-bytes>

set firewall options interface <interface> adjust-mss6 <number-of-bytes>

set firewall receive-redirects [enable | disable]

set firewall send-redirects [enable | disable]

set firewall source-validation [strict | loose | disable]

set firewall state-policy established action [accept | drop | reject]

set firewall state-policy established log enable

set firewall state-policy invalid action [accept | drop | reject]

set firewall state-policy invalid log enable

set firewall state-policy related action [accept | drop | reject]

set firewall state-policy related log enable

set firewall syn-cookies [enable | disable]

set firewall twa-hazards-protection [enable | disable]

set interface ethernet <ethN> firewall [in | out | local] [name | ipv6-name] <rule-set>

set interfaces <dummy | ethernet | bonding | bridge | pppoe> <interface> vrf <name>

set interfaces bond <interface> None None None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces bond <interface> None None None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces bond <interface> None None None None dhcpv6-option pd <id> length <length>

set interfaces bond <interface> address <address | dhcp | dhcpv6>

set interfaces bond <interface> description <description>

set interfaces bond <interface> dhcp-options client-id <description>

set interfaces bond <interface> dhcp-options host-name <hostname>

set interfaces bond <interface> dhcp-options no-default-route

set interfaces bond <interface> dhcp-options vendor-class-id <vendor-id>

set interfaces bond <interface> dhcpv6-options parameters-only

set interfaces bond <interface> dhcpv6-options rapid-commit

set interfaces bond <interface> dhcpv6-options temporary

set interfaces bond <interface> disable

set interfaces bond <interface> disable-flow-control

set interfaces bond <interface> disable-link-detect

set interfaces bond <interface> ipv6 address autoconf

set interfaces bond <interface> ipv6 address eui64 <prefix>

set interfaces bond <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces bond <interface> mtu <mtu>

set interfaces bond <interface> vif <vlan-id>

set interfaces bond <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces bond <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces bond <interface> vif <vlan-id> None None dhcpv6-option pd <id> length <length>

set interfaces bond <interface> vif <vlan-id> address <address | dhcp | dhcpv6>

set interfaces bond <interface> vif <vlan-id> description <description>

set interfaces bond <interface> vif <vlan-id> dhcp-options client-id <description>

set interfaces bond <interface> vif <vlan-id> dhcp-options host-name <hostname>

set interfaces bond <interface> vif <vlan-id> dhcp-options no-default-route

set interfaces bond <interface> vif <vlan-id> dhcp-options vendor-class-id <vendor-id>

set interfaces bond <interface> vif <vlan-id> dhcpv6-options parameters-only

set interfaces bond <interface> vif <vlan-id> dhcpv6-options rapid-commit

set interfaces bond <interface> vif <vlan-id> dhcpv6-options temporary

set interfaces bond <interface> vif <vlan-id> disable

set interfaces bond <interface> vif <vlan-id> disable-link-detect

set interfaces bond <interface> vif <vlan-id> ipv6 address autoconf

set interfaces bond <interface> vif <vlan-id> ipv6 address eui64 <prefix>

set interfaces bond <interface> vif <vlan-id> mac <xx:xx:xx:xx:xx:xx>

set interfaces bond <interface> vif <vlan-id> mtu <mtu>

set interfaces bond <interface> vif <vlan-id> vrf <vrf>

set interfaces bond <interface> vrf <vrf>

set interfaces bonding <interface> arp-monitor interval <time>

set interfaces bonding <interface> arp-monitor target <address>

set interfaces bonding <interface> hash-policy <policy>

set interfaces bonding <interface> member interface <member>

set interfaces bonding <interface> min-links <0-16>

set interfaces bonding <interface> mode <802.3ad | active-backup | broadcast | round-robin | transmit-load-balance | adaptive-load-balance | xor-hash>

set interfaces bonding <interface> primary <interface>

set interfaces bridge <interface> None None None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces bridge <interface> None None None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces bridge <interface> None None None None dhcpv6-option pd <id> length <length>

set interfaces bridge <interface> address <address | dhcp | dhcpv6>

set interfaces bridge <interface> aging <time>

set interfaces bridge <interface> description <description>

set interfaces bridge <interface> dhcp-options client-id <description>

set interfaces bridge <interface> dhcp-options host-name <hostname>

set interfaces bridge <interface> dhcp-options no-default-route

set interfaces bridge <interface> dhcp-options vendor-class-id <vendor-id>

set interfaces bridge <interface> dhcpv6-options parameters-only

set interfaces bridge <interface> dhcpv6-options rapid-commit

set interfaces bridge <interface> dhcpv6-options temporary

set interfaces bridge <interface> disable

set interfaces bridge <interface> disable-flow-control

set interfaces bridge <interface> disable-link-detect

set interfaces bridge <interface> forwarding-delay <delay>

set interfaces bridge <interface> hello-time <interval>

set interfaces bridge <interface> igmp querier

set interfaces bridge <interface> ipv6 address autoconf

set interfaces bridge <interface> ipv6 address eui64 <prefix>

set interfaces bridge <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces bridge <interface> max-age <time>

set interfaces bridge <interface> member interface <member>

set interfaces bridge <interface> member interface <member> allowed-vlan <vlan-id>

set interfaces bridge <interface> member interface <member> cost <cost>

set interfaces bridge <interface> member interface <member> native-vlan <vlan-id>

set interfaces bridge <interface> member interface <member> priority <priority>

set interfaces bridge <interface> mtu <mtu>

set interfaces bridge <interface> stp

set interfaces bridge <interface> vif <vlan-id>

set interfaces bridge <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces bridge <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces bridge <interface> vif <vlan-id> None None dhcpv6-option pd <id> length <length>

set interfaces bridge <interface> vif <vlan-id> address <address | dhcp | dhcpv6>

set interfaces bridge <interface> vif <vlan-id> description <description>

set interfaces bridge <interface> vif <vlan-id> dhcp-options client-id <description>

set interfaces bridge <interface> vif <vlan-id> dhcp-options host-name <hostname>

set interfaces bridge <interface> vif <vlan-id> dhcp-options no-default-route

set interfaces bridge <interface> vif <vlan-id> dhcp-options vendor-class-id <vendor-id>

set interfaces bridge <interface> vif <vlan-id> dhcpv6-options parameters-only

set interfaces bridge <interface> vif <vlan-id> dhcpv6-options rapid-commit

set interfaces bridge <interface> vif <vlan-id> dhcpv6-options temporary

set interfaces bridge <interface> vif <vlan-id> disable

set interfaces bridge <interface> vif <vlan-id> disable-link-detect

set interfaces bridge <interface> vif <vlan-id> ipv6 address autoconf

set interfaces bridge <interface> vif <vlan-id> ipv6 address eui64 <prefix>

set interfaces bridge <interface> vif <vlan-id> mac <xx:xx:xx:xx:xx:xx>

set interfaces bridge <interface> vif <vlan-id> mtu <mtu>

set interfaces bridge <interface> vif <vlan-id> vrf <vrf>

set interfaces bridge <interface> vrf <vrf>

set interfaces dummy <interface> address <address>

set interfaces dummy <interface> description <description>

set interfaces dummy <interface> disable

set interfaces dummy <interface> vrf <vrf>

set interfaces ethernet <ethN> ip ospf bfd

set interfaces ethernet <ethN> ipv6 ospfv3 bfd

set interfaces ethernet <interface> None None None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces ethernet <interface> None None None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces ethernet <interface> None None None None dhcpv6-option pd <id> length <length>

set interfaces ethernet <interface> address <address | dhcp | dhcpv6>

set interfaces ethernet <interface> description <description>

set interfaces ethernet <interface> dhcp-options client-id <description>

set interfaces ethernet <interface> dhcp-options host-name <hostname>

set interfaces ethernet <interface> dhcp-options no-default-route

set interfaces ethernet <interface> dhcp-options vendor-class-id <vendor-id>

set interfaces ethernet <interface> dhcpv6-options parameters-only

set interfaces ethernet <interface> dhcpv6-options rapid-commit

set interfaces ethernet <interface> dhcpv6-options temporary

set interfaces ethernet <interface> disable

set interfaces ethernet <interface> disable-flow-control

set interfaces ethernet <interface> disable-link-detect

set interfaces ethernet <interface> duplex <auto | full | half>

set interfaces ethernet <interface> ipv6 address autoconf

set interfaces ethernet <interface> ipv6 address eui64 <prefix>

set interfaces ethernet <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces ethernet <interface> mirror <interface>

set interfaces ethernet <interface> mtu <mtu>

set interfaces ethernet <interface> speed <auto | 10 | 100 | 1000 | 2500 | 5000 | 10000 | 25000 | 40000 | 50000 | 100000>

set interfaces ethernet <interface> vif <vlan-id>

set interfaces ethernet <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces ethernet <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces ethernet <interface> vif <vlan-id> None None dhcpv6-option pd <id> length <length>

set interfaces ethernet <interface> vif <vlan-id> address <address | dhcp | dhcpv6>

set interfaces ethernet <interface> vif <vlan-id> description <description>

set interfaces ethernet <interface> vif <vlan-id> dhcp-options client-id <description>

set interfaces ethernet <interface> vif <vlan-id> dhcp-options host-name <hostname>

set interfaces ethernet <interface> vif <vlan-id> dhcp-options no-default-route

set interfaces ethernet <interface> vif <vlan-id> dhcp-options vendor-class-id <vendor-id>

set interfaces ethernet <interface> vif <vlan-id> dhcpv6-options parameters-only

set interfaces ethernet <interface> vif <vlan-id> dhcpv6-options rapid-commit

set interfaces ethernet <interface> vif <vlan-id> dhcpv6-options temporary

set interfaces ethernet <interface> vif <vlan-id> disable

set interfaces ethernet <interface> vif <vlan-id> disable-link-detect

set interfaces ethernet <interface> vif <vlan-id> ipv6 address autoconf

set interfaces ethernet <interface> vif <vlan-id> ipv6 address eui64 <prefix>

set interfaces ethernet <interface> vif <vlan-id> mac <xx:xx:xx:xx:xx:xx>

set interfaces ethernet <interface> vif <vlan-id> mtu <mtu>

set interfaces ethernet <interface> vif <vlan-id> vrf <vrf>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> address <address | dhcp | dhcpv6>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> description <description>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcp-options client-id <description>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcp-options host-name <hostname>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcp-options no-default-route

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcp-options vendor-class-id <vendor-id>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-option pd <id> length <length>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-options parameters-only

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-options rapid-commit

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-options temporary

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> disable

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> disable-link-detect

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> ipv6 address autoconf

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> ipv6 address eui64 <prefix>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> mac <xx:xx:xx:xx:xx:xx>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> mtu <mtu>

set interfaces ethernet <interface> vif-s <vlan-id> vif-c <vlan-id> vrf <vrf>

set interfaces ethernet <interface> vrf <vrf>

set interfaces geneve <interface> address <address>

set interfaces geneve <interface> description <description>

set interfaces geneve <interface> disable

set interfaces geneve <interface> disable-flow-control

set interfaces geneve <interface> disable-link-detect

set interfaces geneve <interface> ipv6 address autoconf

set interfaces geneve <interface> ipv6 address eui64 <prefix>

set interfaces geneve <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces geneve <interface> mtu <mtu>

set interfaces geneve <interface> vrf <vrf>

set interfaces geneve gnv0 remote <address>

set interfaces geneve gnv0 vni <vni>

set interfaces l2tpv3 <interface> address <address>

set interfaces l2tpv3 <interface> description <description>

set interfaces l2tpv3 <interface> disable

set interfaces l2tpv3 <interface> disable-flow-control

set interfaces l2tpv3 <interface> disable-link-detect

set interfaces l2tpv3 <interface> encapsulation <udp | ip>

set interfaces l2tpv3 <interface> ipv6 address autoconf

set interfaces l2tpv3 <interface> ipv6 address eui64 <prefix>

set interfaces l2tpv3 <interface> local-ip <address>

set interfaces l2tpv3 <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces l2tpv3 <interface> mtu <mtu>

set interfaces l2tpv3 <interface> peer-session-id <id>

set interfaces l2tpv3 <interface> peer-tunnel-id <id>

set interfaces l2tpv3 <interface> remote-ip <address>

set interfaces l2tpv3 <interface> session-id <id>

set interfaces l2tpv3 <interface> tunnel-id <id>

set interfaces l2tpv3 <interface> vrf <vrf>

set interfaces loopback <interface> address <address>

set interfaces loopback <interface> description <description>

set interfaces macsec <interface> None None None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces macsec <interface> None None None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces macsec <interface> None None None None dhcpv6-option pd <id> length <length>

set interfaces macsec <interface> address <address | dhcp | dhcpv6>

set interfaces macsec <interface> description <description>

set interfaces macsec <interface> dhcp-options client-id <description>

set interfaces macsec <interface> dhcp-options host-name <hostname>

set interfaces macsec <interface> dhcp-options no-default-route

set interfaces macsec <interface> dhcp-options vendor-class-id <vendor-id>

set interfaces macsec <interface> dhcpv6-options parameters-only

set interfaces macsec <interface> dhcpv6-options rapid-commit

set interfaces macsec <interface> dhcpv6-options temporary

set interfaces macsec <interface> disable

set interfaces macsec <interface> disable-flow-control

set interfaces macsec <interface> disable-link-detect

set interfaces macsec <interface> ipv6 address autoconf

set interfaces macsec <interface> ipv6 address eui64 <prefix>

set interfaces macsec <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces macsec <interface> mtu <mtu>

set interfaces macsec <interface> security cipher [gcm-aes-128]

set interfaces macsec <interface> security encrypt

set interfaces macsec <interface> security mka cak <key>

set interfaces macsec <interface> security mka ckn <key>

set interfaces macsec <interface> security mka priority <priority>

set interfaces macsec <interface> security replay-window <window>

set interfaces macsec <interface> source-interface <physical-source>

set interfaces macsec <interface> vrf <vrf>

set interfaces openvpn vtun10 openvpn-option 'persistent-key'

set interfaces openvpn vtun10 openvpn-option 'push &quot;keepalive 1 10&quot;'

set interfaces pppoe <interface> access-concentrator <name>

set interfaces pppoe <interface> authentication password <password>

set interfaces pppoe <interface> authentication user <username>

set interfaces pppoe <interface> connect-on-demand

set interfaces pppoe <interface> default-route

set interfaces pppoe <interface> description <description>

set interfaces pppoe <interface> dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces pppoe <interface> dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces pppoe <interface> dhcpv6-option pd <id> length <length>

set interfaces pppoe <interface> disable

set interfaces pppoe <interface> idle-timeout <time>

set interfaces pppoe <interface> ipv6 address autoconf

set interfaces pppoe <interface> ipv6 enable

set interfaces pppoe <interface> local-address <address>

set interfaces pppoe <interface> mtu <mtu>

set interfaces pppoe <interface> no-peer-dns

set interfaces pppoe <interface> remote-address <address>

set interfaces pppoe <interface> service-name <name>

set interfaces pppoe <interface> source-interface <source-interface>

set interfaces pppoe <interface> vrf <vrf>

set interfaces pseudo-ethernet <interface> None None None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces pseudo-ethernet <interface> None None None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces pseudo-ethernet <interface> None None None None dhcpv6-option pd <id> length <length>

set interfaces pseudo-ethernet <interface> address <address | dhcp | dhcpv6>

set interfaces pseudo-ethernet <interface> description <description>

set interfaces pseudo-ethernet <interface> dhcp-options client-id <description>

set interfaces pseudo-ethernet <interface> dhcp-options host-name <hostname>

set interfaces pseudo-ethernet <interface> dhcp-options no-default-route

set interfaces pseudo-ethernet <interface> dhcp-options vendor-class-id <vendor-id>

set interfaces pseudo-ethernet <interface> dhcpv6-options parameters-only

set interfaces pseudo-ethernet <interface> dhcpv6-options rapid-commit

set interfaces pseudo-ethernet <interface> dhcpv6-options temporary

set interfaces pseudo-ethernet <interface> disable

set interfaces pseudo-ethernet <interface> disable-flow-control

set interfaces pseudo-ethernet <interface> disable-link-detect

set interfaces pseudo-ethernet <interface> ipv6 address autoconf

set interfaces pseudo-ethernet <interface> ipv6 address eui64 <prefix>

set interfaces pseudo-ethernet <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces pseudo-ethernet <interface> mtu <mtu>

set interfaces pseudo-ethernet <interface> source-interface <ethX>

set interfaces pseudo-ethernet <interface> vif <vlan-id>

set interfaces pseudo-ethernet <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces pseudo-ethernet <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces pseudo-ethernet <interface> vif <vlan-id> None None dhcpv6-option pd <id> length <length>

set interfaces pseudo-ethernet <interface> vif <vlan-id> address <address | dhcp | dhcpv6>

set interfaces pseudo-ethernet <interface> vif <vlan-id> description <description>

set interfaces pseudo-ethernet <interface> vif <vlan-id> dhcp-options client-id <description>

set interfaces pseudo-ethernet <interface> vif <vlan-id> dhcp-options host-name <hostname>

set interfaces pseudo-ethernet <interface> vif <vlan-id> dhcp-options no-default-route

set interfaces pseudo-ethernet <interface> vif <vlan-id> dhcp-options vendor-class-id <vendor-id>

set interfaces pseudo-ethernet <interface> vif <vlan-id> dhcpv6-options parameters-only

set interfaces pseudo-ethernet <interface> vif <vlan-id> dhcpv6-options rapid-commit

set interfaces pseudo-ethernet <interface> vif <vlan-id> dhcpv6-options temporary

set interfaces pseudo-ethernet <interface> vif <vlan-id> disable

set interfaces pseudo-ethernet <interface> vif <vlan-id> disable-link-detect

set interfaces pseudo-ethernet <interface> vif <vlan-id> ipv6 address autoconf

set interfaces pseudo-ethernet <interface> vif <vlan-id> ipv6 address eui64 <prefix>

set interfaces pseudo-ethernet <interface> vif <vlan-id> mac <xx:xx:xx:xx:xx:xx>

set interfaces pseudo-ethernet <interface> vif <vlan-id> mtu <mtu>

set interfaces pseudo-ethernet <interface> vif <vlan-id> vrf <vrf>

set interfaces pseudo-ethernet <interface> vrf <vrf>

set interfaces tunnel <interface> address <address>

set interfaces tunnel <interface> description <description>

set interfaces tunnel <interface> disable

set interfaces tunnel <interface> disable-flow-control

set interfaces tunnel <interface> disable-link-detect

set interfaces tunnel <interface> ipv6 address autoconf

set interfaces tunnel <interface> ipv6 address eui64 <prefix>

set interfaces tunnel <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces tunnel <interface> mtu <mtu>

set interfaces tunnel <interface> vrf <vrf>

set interfaces vxlan <interface> address <address>

set interfaces vxlan <interface> description <description>

set interfaces vxlan <interface> disable

set interfaces vxlan <interface> disable-flow-control

set interfaces vxlan <interface> disable-link-detect

set interfaces vxlan <interface> group <address>

set interfaces vxlan <interface> ipv6 address autoconf

set interfaces vxlan <interface> ipv6 address eui64 <prefix>

set interfaces vxlan <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces vxlan <interface> mtu <mtu>

set interfaces vxlan <interface> port <port>

set interfaces vxlan <interface> remote <address>

set interfaces vxlan <interface> source-address <interface>

set interfaces vxlan <interface> source-interface <interface>

set interfaces vxlan <interface> vni <number>

set interfaces vxlan <interface> vrf <vrf>

set interfaces wireless <interface> None None None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces wireless <interface> None None None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces wireless <interface> None None None None dhcpv6-option pd <id> length <length>

set interfaces wireless <interface> address <address | dhcp | dhcpv6>

set interfaces wireless <interface> capabilities ht 40mhz-incapable

set interfaces wireless <interface> capabilities ht auto-powersave

set interfaces wireless <interface> capabilities ht channel-set-width <ht20 | ht40+ | ht40->

set interfaces wireless <interface> capabilities ht delayed-block-ack

set interfaces wireless <interface> capabilities ht dsss-cck-40

set interfaces wireless <interface> capabilities ht greenfield

set interfaces wireless <interface> capabilities ht ldpc

set interfaces wireless <interface> capabilities ht lsig-protection

set interfaces wireless <interface> capabilities ht max-amsdu <3839 | 7935>

set interfaces wireless <interface> capabilities ht short-gi <20 | 40>

set interfaces wireless <interface> capabilities ht smps <static | dynamic>

set interfaces wireless <interface> capabilities ht stbc rx <num>

set interfaces wireless <interface> capabilities ht stbc tx

set interfaces wireless <interface> capabilities require-ht

set interfaces wireless <interface> capabilities require-hvt

set interfaces wireless <interface> capabilities vht antenna-count

set interfaces wireless <interface> capabilities vht antenna-pattern-fixed

set interfaces wireless <interface> capabilities vht beamform <single-user-beamformer | single-user-beamformee | multi-user-beamformer | multi-user-beamformee>

set interfaces wireless <interface> capabilities vht center-channel-freq <freq-1 | freq-2>

set interfaces wireless <interface> capabilities vht channel-set-width <0 | 1 | 2 | 3>

set interfaces wireless <interface> capabilities vht ldpc

set interfaces wireless <interface> capabilities vht link-adaptation

set interfaces wireless <interface> capabilities vht max-mpdu <value>

set interfaces wireless <interface> capabilities vht max-mpdu-exp <value>

set interfaces wireless <interface> capabilities vht short-gi <80 | 160>

set interfaces wireless <interface> capabilities vht stbc rx <num>

set interfaces wireless <interface> capabilities vht stbc tx

set interfaces wireless <interface> capabilities vht tx-powersave

set interfaces wireless <interface> capabilities vht vht-cf

set interfaces wireless <interface> channel <number>

set interfaces wireless <interface> country-code <cc>

set interfaces wireless <interface> description <description>

set interfaces wireless <interface> dhcp-options client-id <description>

set interfaces wireless <interface> dhcp-options host-name <hostname>

set interfaces wireless <interface> dhcp-options no-default-route

set interfaces wireless <interface> dhcp-options vendor-class-id <vendor-id>

set interfaces wireless <interface> dhcpv6-options parameters-only

set interfaces wireless <interface> dhcpv6-options rapid-commit

set interfaces wireless <interface> dhcpv6-options temporary

set interfaces wireless <interface> disable

set interfaces wireless <interface> disable-broadcast-ssid

set interfaces wireless <interface> disable-flow-control

set interfaces wireless <interface> disable-link-detect

set interfaces wireless <interface> expunge-failing-stations

set interfaces wireless <interface> ipv6 address autoconf

set interfaces wireless <interface> ipv6 address eui64 <prefix>

set interfaces wireless <interface> isolate-stations

set interfaces wireless <interface> mac <xx:xx:xx:xx:xx:xx>

set interfaces wireless <interface> max-stations

set interfaces wireless <interface> mgmt-frame-protection

set interfaces wireless <interface> mode <a | b | g | n | ac>

set interfaces wireless <interface> mtu <mtu>

set interfaces wireless <interface> physical-device <device>

set interfaces wireless <interface> reduce-transmit-power <number>

set interfaces wireless <interface> ssid <ssid>

set interfaces wireless <interface> type <access-point | station | monitor>

set interfaces wireless <interface> vif <vlan-id>

set interfaces wireless <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces wireless <interface> vif <vlan-id> None None dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces wireless <interface> vif <vlan-id> None None dhcpv6-option pd <id> length <length>

set interfaces wireless <interface> vif <vlan-id> address <address | dhcp | dhcpv6>

set interfaces wireless <interface> vif <vlan-id> description <description>

set interfaces wireless <interface> vif <vlan-id> dhcp-options client-id <description>

set interfaces wireless <interface> vif <vlan-id> dhcp-options host-name <hostname>

set interfaces wireless <interface> vif <vlan-id> dhcp-options no-default-route

set interfaces wireless <interface> vif <vlan-id> dhcp-options vendor-class-id <vendor-id>

set interfaces wireless <interface> vif <vlan-id> dhcpv6-options parameters-only

set interfaces wireless <interface> vif <vlan-id> dhcpv6-options rapid-commit

set interfaces wireless <interface> vif <vlan-id> dhcpv6-options temporary

set interfaces wireless <interface> vif <vlan-id> disable

set interfaces wireless <interface> vif <vlan-id> disable-link-detect

set interfaces wireless <interface> vif <vlan-id> ipv6 address autoconf

set interfaces wireless <interface> vif <vlan-id> ipv6 address eui64 <prefix>

set interfaces wireless <interface> vif <vlan-id> mac <xx:xx:xx:xx:xx:xx>

set interfaces wireless <interface> vif <vlan-id> mtu <mtu>

set interfaces wireless <interface> vif <vlan-id> vrf <vrf>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> address <address | dhcp | dhcpv6>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> description <description>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcp-options client-id <description>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcp-options host-name <hostname>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcp-options no-default-route

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcp-options vendor-class-id <vendor-id>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-option pd <id> interface <delegatee> address <address>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-option pd <id> interface <delegatee> sla-id <id>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-option pd <id> length <length>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-options parameters-only

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-options rapid-commit

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> dhcpv6-options temporary

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> disable

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> disable-link-detect

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> ipv6 address autoconf

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> ipv6 address eui64 <prefix>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> mac <xx:xx:xx:xx:xx:xx>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> mtu <mtu>

set interfaces wireless <interface> vif-s <vlan-id> vif-c <vlan-id> vrf <vrf>

set interfaces wireless <interface> vrf <vrf>

set interfaces wirelessmodem <interface> apn <apn>

set interfaces wirelessmodem <interface> backup distance <metric>

set interfaces wirelessmodem <interface> connect-on-demand

set interfaces wirelessmodem <interface> description <description>

set interfaces wirelessmodem <interface> device <tty>

set interfaces wirelessmodem <interface> disable

set interfaces wirelessmodem <interface> no-peer-dns

set interfaces wirelessmodem <interface> vrf <vrf>

set protocols bfd peer <address>

set protocols bfd peer <address> echo-mode

set protocols bfd peer <address> interval [receive | transmit] <10-60000>

set protocols bfd peer <address> interval echo-interval <10-60000>

set protocols bfd peer <address> interval multiplier <2-255>

set protocols bfd peer <address> multihop

set protocols bfd peer <address> shutdown

set protocols bfd peer <address> source [address <address> | interface <interface>]

set protocols bgp <asn>

set protocols bgp <asn> neighbor <address> bfd

set protocols bgp <asn> parameters bestpath as-path confed

set protocols bgp <asn> parameters bestpath as-path ignore

set protocols bgp <asn> parameters bestpath as-path multipath-relax

set protocols bgp <asn> parameters router-id

set protocols bgp <asn> peer-group <group> bfd

set protocols igmp interface <interface query-interval <seconds>

set protocols igmp interface <interface query-max-response-time <deciseconds>

set protocols igmp interface <interface> join <multicast-address> source <IP-address>

set protocols igmp interface <interface> version <version-number>

set protocols igmp interface eth1

set protocols igmp-proxy disable

set protocols igmp-proxy disable-quickleave

set protocols igmp-proxy interface <interface> alt-subnet <network>

set protocols igmp-proxy interface <interface> role <upstream | downstream>

set protocols mpls ldp discovery hello-holdtime <seconds>

set protocols mpls ldp discovery hello-interval <seconds>

set protocols mpls ldp discovery session-ipv4-holdtime <seconds>

set protocols mpls ldp discovery session-ipv6-holdtime <seconds>

set protocols mpls ldp discovery transport-ipv4-address <IPv4 address>

set protocols mpls ldp discovery transport-ipv6-address <IPv6 address>

set protocols mpls ldp export ipv4 explicit-null

set protocols mpls ldp export ipv6 explicit-null

set protocols mpls ldp interface <interface>

set protocols mpls ldp neighbor <IPv4 address> password <password>

set protocols mpls ldp router-id <address>

set protocols nhrp tunnel <tunnel> cisco-authentication <secret>

set protocols nhrp tunnel <tunnel> dynamic-map <address> nbma-domain-name <fqdn>

set protocols nhrp tunnel <tunnel> holding-time <timeout>

set protocols nhrp tunnel <tunnel> map cisco

set protocols nhrp tunnel <tunnel> map nbma-address <address>

set protocols nhrp tunnel <tunnel> map register

set protocols nhrp tunnel <tunnel> multicast <dynamic | nhs>

set protocols nhrp tunnel <tunnel> non-caching

set protocols nhrp tunnel <tunnel> redirect

set protocols nhrp tunnel <tunnel> shortcut

set protocols nhrp tunnel <tunnel> shortcut-destination

set protocols nhrp tunnel <tunnel> shortcut-target <address>

set protocols nhrp tunnel <tunnel> shortcut-target <address> holding-time <timeout>

set protocols pim int <interface> hello <seconds>

set protocols pim interface <interface-name>

set protocols pim interface <interface> dr-priority <value>

set protocols pim rp address <address> group <multicast-address/mask-bits>

set protocols pim rp keep-alive-timer <seconds>

set protocols static arp <address> hwaddr <mac>

set protocols static interface-route <subnet> next-hop-interface <interface>

set protocols static interface-route <subnet> next-hop-interface <interface> disable

set protocols static interface-route <subnet> next-hop-interface <interface> distance <distance>

set protocols static interface-route6 <subnet> next-hop-interface <interface>

set protocols static interface-route6 <subnet> next-hop-interface <interface> disable

set protocols static interface-route6 <subnet> next-hop-interface <interface> distance <distance>

set protocols static route 0.0.0.0/0 next-hop <address>

set protocols static route <subnet> blackhole

set protocols static route <subnet> blackhole distance <distance>

set protocols static route <subnet> next-hop <address>

set protocols static route <subnet> next-hop <address> disable

set protocols static route <subnet> next-hop <address> distance <distance>

set protocols static route6 <subnet> blackhole

set protocols static route6 <subnet> blackhole distance <distance>

set protocols static route6 <subnet> next-hop <address>

set protocols static route6 <subnet> next-hop <address> disable

set protocols static route6 <subnet> next-hop <address> distance <distance>

set protocols vrf <name> static interface-route <subnet> next-hop-interface <interface>

set protocols vrf <name> static interface-route <subnet> next-hop-interface <interface> disable

set protocols vrf <name> static interface-route <subnet> next-hop-interface <interface> distance <distance>

set protocols vrf <name> static interface-route6 <subnet> next-hop-interface <interface>

set protocols vrf <name> static interface-route6 <subnet> next-hop-interface <interface> disable

set protocols vrf <name> static interface-route6 <subnet> next-hop-interface <interface> distance <distance>

set protocols vrf <name> static route <subnet> blackhole

set protocols vrf <name> static route <subnet> blackhole distance <distance>

set protocols vrf <name> static route <subnet> next-hop <address>

set protocols vrf <name> static route <subnet> next-hop <address> disable

set protocols vrf <name> static route <subnet> next-hop <address> distance <distance>

set protocols vrf <name> static route <subnet> next-hop <address> next-hop-vrf <default | vrf-name>

set protocols vrf <name> static route6 <subnet> blackhole

set protocols vrf <name> static route6 <subnet> blackhole distance <distance>

set protocols vrf <name> static route6 <subnet> next-hop <address>

set protocols vrf <name> static route6 <subnet> next-hop <address> disable

set protocols vrf <name> static route6 <subnet> next-hop <address> distance <distance>

set protocols vrf <name> static route6 <subnet> next-hop <address> next-hop-vrf <default | vrf-name>

set service broadcast-relay disable

set service broadcast-relay id <n> description <description>

set service broadcast-relay id <n> disable

set service broadcast-relay id <n> interface <interface>

set service broadcast-relay id <n> port <port>

set service console-server <device> data-bits [7 | 8]

set service console-server <device> description <string>

set service console-server <device> parity [even | odd | none]

set service console-server <device> speed [ 300 | 1200 | 2400 | 4800 | 9600 | 19200 | 38400 | 57600 | 115200 ]

set service console-server <device> ssh port <port>

set service console-server <device> stop-bits [1 | 2]

set service dhcp-relay interface <interface>

set service dhcp-relay relay-options hop-count <count>

set service dhcp-relay relay-options max-size <size>

set service dhcp-relay relay-options relay-agents-packet <append | discard | forward | replace>

set service dhcp-relay relay-options relay-agents-packets discard

set service dhcp-relay server <server>

set service dhcp-server shared-network-name <name> authoritative

set service dhcp-server shared-network-name <name> subnet <subnet> default-router <address>

set service dhcp-server shared-network-name <name> subnet <subnet> dns-server <address>

set service dhcp-server shared-network-name <name> subnet <subnet> domain-name <domain-name>

set service dhcp-server shared-network-name <name> subnet <subnet> domain-search <domain-name>

set service dhcp-server shared-network-name <name> subnet <subnet> exclude <address>

set service dhcp-server shared-network-name <name> subnet <subnet> failover local-address <address>

set service dhcp-server shared-network-name <name> subnet <subnet> failover name <name>

set service dhcp-server shared-network-name <name> subnet <subnet> failover peer-address <address>

set service dhcp-server shared-network-name <name> subnet <subnet> failover status <primary | secondary>

set service dhcp-server shared-network-name <name> subnet <subnet> lease <time>

set service dhcp-server shared-network-name <name> subnet <subnet> range <n> start <address>

set service dhcp-server shared-network-name <name> subnet <subnet> range <n> stop <address>

set service dhcp-server shared-network-name <name> subnet <subnet> static-mapping <description> ip-address <address>

set service dhcp-server shared-network-name <name> subnet <subnet> static-mapping <description> mac-address <address>

set service dhcpv6-relay listen-interface <interface>

set service dhcpv6-relay max-hop-count 'count'

set service dhcpv6-relay upstream-interface <interface> address <server>

set service dhcpv6-relay use-interface-id-option

set service dhcpv6-server preference <preference value>

set service dhcpv6-server shared-network-name <name> subnet <prefix> lease-time {default | maximum | minimum}

set service dhcpv6-server shared-network-name <name> subnet <prefix> nis-domain <domain-name>

set service dhcpv6-server shared-network-name <name> subnet <prefix> nis-server <address>

set service dhcpv6-server shared-network-name <name> subnet <prefix> nisplus-domain <domain-name>

set service dhcpv6-server shared-network-name <name> subnet <prefix> nisplus-server <address>

set service dhcpv6-server shared-network-name <name> subnet <prefix> prefix-delegation start <address> prefix-length <length>

set service dhcpv6-server shared-network-name <name> subnet <prefix> prefix-delegation start <address> stop <address>

set service dhcpv6-server shared-network-name <name> subnet <prefix> sip-server <address | fqdn>

set service dhcpv6-server shared-network-name <name> subnet <prefix> sntp-server-address <address>

set service dns dynamic interface <interface> rfc2136 <service-name>

set service dns dynamic interface <interface> rfc2136 <service-name> key <keyfile>

set service dns dynamic interface <interface> rfc2136 <service-name> record <record>

set service dns dynamic interface <interface> rfc2136 <service-name> server <server>

set service dns dynamic interface <interface> rfc2136 <service-name> ttl <ttl>

set service dns dynamic interface <interface> rfc2136 <service-name> zone <zone>

set service dns dynamic interface <interface> service <service> host-name <hostname>

set service dns dynamic interface <interface> service <service> login <username>

set service dns dynamic interface <interface> service <service> password <password>

set service dns dynamic interface <interface> service <service> protocol <protocol>

set service dns dynamic interface <interface> service <service> server <server>

set service dns dynamic interface <interface> use-web skip <pattern>

set service dns dynamic interface <interface> use-web url <url>

set service dns forwarding allow-from <network>

set service dns forwarding dnssec <off | process-no-validate | process | log-fail | validate>

set service dns forwarding domain <domain-name> server <address>

set service dns forwarding ignore-hosts-file

set service dns forwarding listen-address

set service dns forwarding max-cache-entries

set service dns forwarding name-server <address>

set service dns forwarding negative-ttl

set service dns forwarding system

set service lldp

set service lldp interface <interface>

set service lldp interface <interface> disable

set service lldp legacy-protocols <cdp|edp|fdp|sonmp>

set service lldp management-address <address>

set service lldp snmp enable

set service mdns repeater disable

set service mdns repeater interface <interface>

set service pppoe-server access-concentrator <name>

set service pppoe-server authentication local-users username <name> password <password>

set service pppoe-server authentication local-users username <name> rate-limit <download | upload>

set service pppoe-server authentication mode <local | radius>

set service pppoe-server authentication radius dynamic-author <key | port | server>

set service pppoe-server authentication radius rate-limit enable

set service pppoe-server authentication radius server <address> key <secret>

set service pppoe-server client-ip-pool start <address>

set service pppoe-server client-ip-pool stop <address>

set service pppoe-server client-ip-pool subnet <address>

set service pppoe-server client-ipv6-pool delegate <address> delegation-prefix <number-of-bits>

set service pppoe-server client-ipv6-pool prefix <address> mask <number-of-bits>

set service pppoe-server interface <interface>

set service pppoe-server interface <interface> <vlan-id | vlan range> <text>

set service pppoe-server local-ip <address>

set service pppoe-server name-server <address>

set service pppoe-server pado-delay <number-of-ms> sessions <number-of-sessions>

set service router-advert interface <interface> ....

set service router-advert interface <interface> no-send-advert

set service router-advert interface <interface> prefix 2001:DB8::/32

set service ssh access-control <allow | deny> <group | user> <name>

set service ssh ciphers <cipher>

set service ssh client-keepalive-interval <interval>

set service ssh disable-host-validation

set service ssh disable-password-authentication

set service ssh key-exchange <kex>

set service ssh listen-address <address>

set service ssh loglevel <quiet | fatal | error | info | verbose>

set service ssh macs <mac>

set service ssh port <port>

set service ssh vrf <name>

set service tftp-server allow-upload

set service tftp-server directory <directory>

set service tftp-server listen-address <address>

set system config-management commit-archive location <URI>

set system config-management commit-revisions <N>

set system console device <device>

set system console device <device> speed <speed>

set system domain-name <domain>

set system domain-search domain <domain>

set system flow-accounting buffer-size <buffer size>

set system flow-accounting disable-imt

set system flow-accounting interface <interface>

set system flow-accounting netflow engine-id <id>

set system flow-accounting netflow max-flows <n>

set system flow-accounting netflow sampling-rate <rate>

set system flow-accounting netflow server <address>

set system flow-accounting netflow source-ip <address>

set system flow-accounting netflow timeout expiry-interval <interval>

set system flow-accounting netflow version <version>

set system flow-accounting sflow agent-address <address>

set system flow-accounting sflow sampling-rate <rate>

set system flow-accounting sflow server <address>

set system flow-accounting syslog-facility <facility>

set system host-name <hostname>

set system ip arp table-size <number>

set system ip disable-forwarding

set system ip multipath layer4-hashing

set system ipv6 disable

set system ipv6 disable-forwarding

set system ipv6 multipath layer4-hashing

set system ipv6 neighbor table-size <number>

set system ipv6 strict-dad

set system lcd device <device>

set system lcd model <model>

set system login banner post-login <message>

set system login banner pre-login <message>

set system login radius server <address> disable

set system login radius server <address> port <port>

set system login radius server <address> secret <secret>

set system login radius server <address> timeout <timeout>

set system login radius source-address <address>

set system login user <name> authentication encrypted-password <password>

set system login user <name> authentication plaintext-password <password>

set system login user <name> full-name "<string>"

set system login user <username> authentication public-keys <identifier> key <key>

set system login user <username> authentication public-keys <identifier> type <type>

set system name-server <address>

set system ntp allow-clients address <address>

set system ntp listen-address <address>

set system ntp server <address>

set system option ctrl-alt-delete <ignore | reboot | poweroff>

set system option http-client source-address <address>

set system option http-client source-interface <interface>

set system option keyboard-layout <us | fr | de | fi | no | dk>

set system option performance < throughput | latency >

set system option reboot-on-panic

set system option startup-beep

set system proxy password <password>

set system proxy port <port>

set system proxy url <url>

set system proxy username <username>

set system static-host-mapping host-name <hostname> alias <alias>

set system static-host-mapping host-name <hostname> inet <address>

set system syslog console facility <keyword> level <keyword>

set system syslog file <filename> archive file <number>

set system syslog file <filename> archive size <size>

set system syslog file <filename> facility <keyword> level <keyword>

set system syslog host <address> facility <keyword> level <keyword>

set system syslog host <address> facility <keyword> protocol <udp|tcp>

set system syslog user <username> facility <keyword> level <keyword>

set system task-scheduler task <task> crontab-spec <spec>

set system task-scheduler task <task> executable arguments <args>

set system task-scheduler task <task> executable path <path>

set system task-scheduler task <task> interval <interval>

set system time-zone <timezone>

set traffic-policy drop-tail <policy-name> queue-limit <number-of-packets>

set traffic-policy fair-queue <policy-name>

set traffic-policy fair-queue <policy-name> hash-interval <seconds>`

set traffic-policy fair-queue <policy-name> queue-limit <limit>

set traffic-policy fq-codel <policy name> codel-quantum <bytes>

set traffic-policy fq-codel <policy name> flows <number-of-flows>

set traffic-policy fq-codel <policy name> interval <miliseconds>

set traffic-policy fq-codel <policy-name> queue-limit <number-of-packets>`

set traffic-policy fq-codel <policy-name> target <miliseconds>`

set traffic-policy limiter <policy-name> class <class ID> match <match-name> description <description>

set traffic-policy limiter <policy-name> class <class ID> priority <value>

set traffic-policy limiter <policy-name> class <class-ID> bandwidth <rate>

set traffic-policy limiter <policy-name> class <class-ID> burst <burst-size>

set traffic-policy limiter <policy-name> default bandwidth <rate>

set traffic-policy limiter <policy-name> default burst <burst-size>

set traffic-policy network-emulator <policy-name> bandwidth <rate>

set traffic-policy network-emulator <policy-name> burst <burst-size>

set traffic-policy network-emulator <policy-name> network-delay <delay>

set traffic-policy network-emulator <policy-name> packet-corruption <percent>

set traffic-policy network-emulator <policy-name> packet-loss <percent>`

set traffic-policy network-emulator <policy-name> packet-reordering <percent>`

set traffic-policy network-emulator <policy-name> queue-limit <limit>

set traffic-policy priority-queue <policy-name> class <class-ID> queue-limit <limit>`

set traffic-policy random-detect <policy-name> bandwidth <bandwidth>

set traffic-policy random-detect <policy-name> precedence <IP-precedence-value> average-packet <bytes>

set traffic-policy random-detect <policy-name> precedence <IP-precedence-value> mark-probability <value>

set traffic-policy random-detect <policy-name> precedence <IP-precedence-value> maximum-threshold <packets>

set traffic-policy random-detect <policy-name> precedence <IP-precedence-value> minimum-threshold <packets>

set traffic-policy random-detect <policy-name> precedence <IP-precedence-value> queue-limit <packets>

set traffic-policy rate-control <policy-name> bandwidth <rate>

set traffic-policy rate-control <policy-name> burst <burst-size>

set traffic-policy rate-control <policy-name> latency

set traffic-policy round-robin <policy name> class <class ID> queue-limit <packets>

set traffic-policy round-robin <policy name> class <class-ID> quantum <packets>

set traffic-policy shaper <policy-name> bandwidth <rate>

set traffic-policy shaper <policy-name> class <class-ID> bandwidth <rate>

set traffic-policy shaper <policy-name> class <class-ID> burst <bytes>

set traffic-policy shaper <policy-name> class <class-ID> ceiling <bandwidth>

set traffic-policy shaper <policy-name> class <class-ID> priority <0-7>

set vpn sstp authentication local-users username <user> disable

set vpn sstp authentication local-users username <user> password <pass>

set vpn sstp authentication local-users username <user> rate-limit download <bandwidth>

set vpn sstp authentication local-users username <user> rate-limit upload <bandwidth>

set vpn sstp authentication local-users username <user> static-ip <address>

set vpn sstp authentication mode <local | radius>

set vpn sstp authentication protocols <pap | chap | mschap | mschap-v2>

set vpn sstp authentication radius acct-timeout <timeout>

set vpn sstp authentication radius dynamic-author key <secret>

set vpn sstp authentication radius dynamic-author port <port>

set vpn sstp authentication radius dynamic-author server <address>

set vpn sstp authentication radius max-try <number>

set vpn sstp authentication radius nas-identifier <identifier>

set vpn sstp authentication radius nas-ip-address <address>

set vpn sstp authentication radius rate-limit attribute <attribute>

set vpn sstp authentication radius rate-limit enable

set vpn sstp authentication radius rate-limit vendor

set vpn sstp authentication radius server <server> disable

set vpn sstp authentication radius server <server> fail-time <time>

set vpn sstp authentication radius server <server> key <secret>

set vpn sstp authentication radius server <server> port <port>

set vpn sstp authentication radius source-address <address>

set vpn sstp authentication radius timeout <timeout>

set vpn sstp client-ip-pool subnet <subnet>

set vpn sstp client-ipv6-pool delegate <address> delegation-prefix <number-of-bits>

set vpn sstp client-ipv6-pool prefix <address> mask <number-of-bits>

set vpn sstp gateway-address <gateway>

set vpn sstp name-server <address>

set vpn sstp ppp-options lcp-echo-failure <number>

set vpn sstp ppp-options lcp-echo-interval <interval>

set vpn sstp ppp-options lcp-echo-timeout

set vpn sstp ppp-options mppe <require | prefer | deny>

set vpn sstp ssl ca-cert-file <file>

set vpn sstp ssl cert-file <file>

set vpn sstp ssl key-file <file>

set vrf bind-to-all

set vrf name <name>

set vrf name <name> table <id>

set zone-policy zone <name> default-action [drop | reject]

set zone-policy zone <name> description

set zone-policy zone <name> from <name> firewall ipv6-name <rule-set>

set zone-policy zone <name> from <name> firewall name <rule-set>

set zone-policy zone <name> interface <interfacenames>

set zone-policy zone <name> local-zone

show